SmartGit 6 on OS X 10.6.8

Officially, SmartGit 6 requires OS X 10.7 or higher, but, depending on your system, it may be possible to get it starting on OS X 10.6.8, too: right-click SmartGit.app, click “Show Package Content”, navigate into “Contents/MacOS” and open “SmartGit” in a text editor of your choice. There you’ll find the line

if [ `sw_vers -productVersion | cut -d'.' -f2` -lt "7" ] ;

Change the 7 to a 6

if [ `sw_vers -productVersion | cut -d'.' -f2` -lt "6" ] ;

and save the file.

Author: Thomas Singer

Thomas is one of the two CEOs of syntevo. He is a passionated Java developer and likes to design clean and consistent user interfaces.